• Entrar / registo
  • Language
    • English
    • Deutsch
    • Française
    • Español
    • Português
    • Italia
    • Русский
    • 日本語
    • 한국어
    • 简体中文
    • 繁體中文
user image

I want to ask why LM393 can't output low level?

Hardware design
March 2, 2021 by Jacobi 933

The circuit I used is Figure 1 and the simulation is Figure 2

The design idea is that 393 is connected to a 5V voltage, the external circuit signal input is the inverting input terminal, and the voltage at the non-inverting input terminal is about 1.25V. When the external circuit detects a signal, the input voltage is about 1.36V. If no signal is detected , It is about 1.10V. Then, use a multimeter to measure the output voltage of 393. One of the inputs jumps between 2.2V and 2.6V, and the other output jumps between 2.8 and 3.1V.

What I want to get is a low voltage input signal, input into STM32. How can I improve it?

图二

图一

Todos os comentários

user image

Casper postado em March 2, 2021

(One input jumps between 2.2V and 2.6V, and the other output jumps between 2.8 and 3.1V.) What does this mean? The description must be accurate, not vague, so that others will not be easy to understand!

0
user image

Murray postado em March 2, 2021

If it is not affected by your external resistance, it is the difference of the chip (the difference within a chip should be very small).

0
user image

Dawn postado em March 2, 2021

It seems that your oscilloscope is in AC mode. Change it to DC and try again. I don't know how much this affects.

0

Escreva uma resposta

Você precisa fazer login para responder. Entrar | registo

Seleccione a sua localização